z

Unable to connect: SSLenabler not supported under OSX Lion

Chat about twofo and other information sharing portals.

Moderator: Operators

shruikanshade
Posts: 3
Joined: Sun Oct 30, 2011 12:20 pm

Unable to connect: SSLenabler not supported under OSX Lion

Postby shruikanshade » Fri Nov 18, 2011 5:01 am

Hi all,

I'm a new user, and have been following the instructions given on the wiki to try and connect to the hub using my Mac. All is well up until the instruction:

"Download and install SSL Enabler, hosted at http://www.twofo.co.uk/resources/SSLEnabler.dmg"

After downloading (and converting) the application, I receive the following error message:

"You cannot open the application SSL Enabler.dmg because PowerPC applications are no longer supported."

A little bit of research has revealed that Apple has completely dropped Rosetta support in Lion, and as such Lion will never support PowerPC applications. I was wondering if anyone has managed to find a different way of installing and configuring stunnel which isnt mentioned in the wiki?
User avatar
astropoint
The life and soul of the party
Posts: 1146
Joined: Tue Oct 04, 2005 6:50 pm
Location: Newcastle-Under-Lyme
Contact:

Re: Unable to connect: SSLenabler not supported under OSX L

Postby astropoint » Fri Nov 18, 2011 1:19 pm

There's nothing that we know of unfortunately (otherwise it would be on the wiki).
Somewhere deep down I do feel that just compiling stunnel and running it ought to work, but we haven't had anybody figure out yet where to configure the .conf file for it to make it connect to twofo, so if you do find out at any point do pretty please tell us :P
In the mean time I am afraid you will have to use valknut as that doesn't require stunnel.
Phira
Posts: 1
Joined: Mon Jan 18, 2010 3:20 pm

Re: Unable to connect: SSLenabler not supported under OSX L

Postby Phira » Wed Oct 03, 2012 7:09 pm

Hi, I had the same problem but ended up skipping that step and going straight to downloading shakespeer. However, as a returning student to campus, despite the fact that I had deleted shakespeer it still remembered all the settings I had set some 3 years ago. This gave me hope that it would work so after updating the directory to upload that had changed i tried connecting again. Unfortunately when I try it tells me failed to connect to hub 127.0.0.1:8000: connection refused. I am hoping that it is something else than this ssl problem because I really don't want to bother with valknut :p. Does anyone have any idea ?
Thanks
User avatar
astropoint
The life and soul of the party
Posts: 1146
Joined: Tue Oct 04, 2005 6:50 pm
Location: Newcastle-Under-Lyme
Contact:

Re: Unable to connect: SSLenabler not supported under OSX L

Postby astropoint » Wed Oct 03, 2012 8:19 pm

Do you know if stunnel is installed and/or running still? Stunnel is required in order to use shakespeer on campus effectively Check your task manager (equivalent) to see running processes, or maybe try running stunnel manually from wherever it is installed.
Failing that, you could try connecting without stunnel, but that may or may not working depending on how good ITS are at blocking things this week (it comes and goes and may randomly stop working). Just connect shakespeer directly to hub.twofo.co.uk:4144

Good luck

Who is online

Users browsing this forum: No registered users and 1 guest